jalapeno plants wilting leaves a bumps all over


Joined
Mar 13, 2021
Messages
13
Reaction score
4
Country
United States
hello, i have a few jalapeno plants that started to wilt a little bit and upon closer inspection i see they have some bumps on the top and underside of the leaves, also the stem seems to be a bit of a dark redish brown color, although that might be a different problem. From my research it seems i may have a problem called edema. The soil that i use does hold water longer than i would like, which might have led to a slight overwater. Any input and solutions are greatly appreciated.
thank you friends. bellow are some pics
 

Attachments

Ad

Advertisements

Logan

Logan
Joined
Mar 21, 2017
Messages
8,473
Reaction score
5,924
Location
redditch west Midlands UK
Hardiness Zone
1a
Country
United Kingdom
Hello and welcome to GF
Let them drain somewhere also if you can take them out of the pot for a while, or put them somewhere that's warm that will help the water to evaporate faster. Next time when you water don't put so much on and let them dry out in-between watering.
 
Joined
Feb 2, 2014
Messages
9,014
Reaction score
4,191
Location
Tarpley Tx
Hardiness Zone
8b
Country
United States
If you growing medium has too much coir or peat it will retain too much moisture. Either don't water as often or change soils.
 
Joined
Mar 13, 2021
Messages
13
Reaction score
4
Country
United States
thanks for the answers. Im using fox farm ocean forest soil and it holds too much water so i will be making a custom mix for when i replant. Also i have only fed them a product called azomite which is a blend of trace minerals. they are about 2 weeks old and i feel like it could be a calcium and magnesium deficiency. Also the stems and nodes are getting a dark redish brown color on them. does it look normal to you guys?
 

Attachments

Joined
Feb 2, 2014
Messages
9,014
Reaction score
4,191
Location
Tarpley Tx
Hardiness Zone
8b
Country
United States
thanks for the answers. Im using fox farm ocean forest soil and it holds too much water so i will be making a custom mix for when i replant. Also i have only fed them a product called azomite which is a blend of trace minerals. they are about 2 weeks old and i feel like it could be a calcium and magnesium deficiency. Also the stems and nodes are getting a dark redish brown color on them. does it look normal to you guys?
I wouldn't say it looks normal but not that bad either. Azomite has no NPK values. What I would do is start fertilizing with a good organic NPK fertilizer. Also, azomite has calcium and magnesium but that doesn't necessarily mean that the plant is able to uptake it. I would also give the plant a handful of epsom salts which changes the makeup of the calcium and magnesium into a form that the plant can uptake it. It won't hurt anything and could possibly be the complete answer. Many times perfectly healthy pepper plants get a black color along the stems but this is just part of the DNA of the plant and is not a worry.
 
Joined
Mar 13, 2021
Messages
13
Reaction score
4
Country
United States
Chuck thank you so much. yes i have seen that color on other pepper plants so i was not so worried about that. I transplanted one today into a bigger pot with some bat guano and seabird guano mixed into the soil. The roots are healthy and white :) I have not used Epsom salt in a long time, but i do remember it helping out with nutrient uptake on my heavy feeders. i will go to the store and buy some. will any epsom salt work? or is there something i should watch out for in particular? i also added a bit of mycorrhiza fungus to the root zone, im sure that will help with nutrient uptake also. I plan to make compost teas to feed with but for now i will just be top soil feeding. here is a picture of the roots
happy growing everyone :)
 

Attachments

Ad

Advertisements

Joined
Feb 2, 2014
Messages
9,014
Reaction score
4,191
Location
Tarpley Tx
Hardiness Zone
8b
Country
United States
Chuck thank you so much. yes i have seen that color on other pepper plants so i was not so worried about that. I transplanted one today into a bigger pot with some bat guano and seabird guano mixed into the soil. The roots are healthy and white :) I have not used Epsom salt in a long time, but i do remember it helping out with nutrient uptake on my heavy feeders. i will go to the store and buy some. will any epsom salt work? or is there something i should watch out for in particular? i also added a bit of mycorrhiza fungus to the root zone, im sure that will help with nutrient uptake also. I plan to make compost teas to feed with but for now i will just be top soil feeding. here is a picture of the roots
happy growing everyone :)
You really need a "balanced" fertilizer. There are numerous bat and seabird guano suppliers and depending on what you buy might be something you don't need or want. So be careful of the NPK values of what you get. I wouldn't buy the epsom salts that have an aroma built into it such as lavender, peach, mint etc.
 
Joined
Mar 13, 2021
Messages
13
Reaction score
4
Country
United States
You really need a "balanced" fertilizer. There are numerous bat and seabird guano suppliers and depending on what you buy might be something you don't need or want. So be careful of the NPK values of what you get. I wouldn't buy the epsom salts that have an aroma built into it such as lavender, peach, mint etc.
the products i currently use is sparetime organics. the bat Guano is 4-6-2 and the seabird guano is 13-10-2. i have used them before with good results. Now that i think more about it, i should have left out the sea bird guano and used a bit of bloodmeal 12-0-0 to help in the vegetative growing state.
ps. im a mostly organic grower.
 

Logan

Logan
Joined
Mar 21, 2017
Messages
8,473
Reaction score
5,924
Location
redditch west Midlands UK
Hardiness Zone
1a
Country
United Kingdom
If you used a multi purpose compost you wouldn't need to feed them until they started flowering. Then use a tomato food that is organic, it's simple and less worrying. The colour of the stems are normal.
 
Joined
Mar 13, 2021
Messages
13
Reaction score
4
Country
United States
I let the plants dry and also turned on the fan to high and they are starting to look better. The plant that I transplanted and gave nutrients to seems to be recovering a little faster but not by much. I believe my edema issues were caused by slight overwatering and not enough ventilation. I noticed that my fans were on the same schedule as my lights, when my lights turned off so did my fans. my fans are on 24/7 now.
 

Logan

Logan
Joined
Mar 21, 2017
Messages
8,473
Reaction score
5,924
Location
redditch west Midlands UK
Hardiness Zone
1a
Country
United Kingdom
I let the plants dry and also turned on the fan to high and they are starting to look better. The plant that I transplanted and gave nutrients to seems to be recovering a little faster but not by much. I believe my edema issues were caused by slight overwatering and not enough ventilation. I noticed that my fans were on the same schedule as my lights, when my lights turned off so did my fans. my fans are on 24/7 now.
That's great news.
 
Ad

Advertisements

Joined
Mar 13, 2021
Messages
13
Reaction score
4
Country
United States
If you used a multi purpose compost you wouldn't need to feed them until they started flowering. Then use a tomato food that is organic, it's simple and less worrying. The colour of the stems are normal.
do you make the compost yourself? I don't know were to get some good quality compost
 
Ad

Advertisements


Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Top