Issue with Kangaroo Paw Fern

Joined
Jan 31, 2023
Messages
1
Reaction score
0
Location
USA
Country
United States
I have this Kangaroo Paw fern I got as a gift about 2 years ago. From a distance it looks fine and has been doing pretty well over the 2 years. There are 2 issues though I am seeing...

1. There is not much growth at all from the inside of the plant/pot. Most of the leaves are around the exterior "branches" (?).
2. Also there is this white substance that grows on the "branches" inside the pot. I am assuming it is mold? I have had to rip out entire sections because the branch starts to rot away. This has happened 2-3 times in the last 6-8 months.

The plant is in indirect light and I water the plant every 2-3 weeks, enough to let it drip out the bottom (and remove the excess water afterwards) and I only water when the top part of the soil is dry and the pot is feeling "light". I use Miracle Grow indoor plant food from about March to September, about once a month

Any ideas?
Thanks
 

Attachments

  • image_50766337.JPG
    image_50766337.JPG
    335.5 KB · Views: 7
  • image_50740481.JPG
    image_50740481.JPG
    220.5 KB · Views: 8

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Similar Threads


Members online

No members online now.

Forum statistics

Threads
27,010
Messages
259,621
Members
13,452
Latest member
tabby

Latest Threads

Top