What's wrong with my monstera adansonii? (with photos)


Joined
Mar 8, 2020
Messages
1
Reaction score
0
Country
Australia
My adansonii is actually two seperate vines planted in the same pot.

One vine has put out leaves with yellow lines on them (see first pic). I thought this could be mosaic virus, though the veins are still green and the leaves aren't deformed in any way other than the yellow markings. (Also, the shiny spots on the leaf are just due to some neem oil.) New leaves are still coming out, although slowly.

monstera1.jpg


The second vine has been fine up until now, and growing quickly (although smaller leaves than the yellowed vine). However, the last few leaves to pop out have now developed these raised yelowish spots, and have brown spots as well (see next two pics).

monstera2.jpg


monstera3.jpg


Has the second vine caught mosaic virus from the first vine? Is it caused by pests? I did fertilise 5 or 6 weeks ago, so could it be due to fertiliser burn? The yellow marks in the first pic were already there before I fertilised though, so I doubt this.

Any other ideas..? After a tonne of googling I still can't any pictures online that look like the leaf in the first pic.
 
Ad

Advertisements

Joined
Feb 21, 2020
Messages
871
Reaction score
249
Country
United States
If I may respond to your question. It appears to be getting less than optimal light. If the pot is pretty large, you need to be careful to allow the top inch or so of soil to get quite dry before watering again. Luckily your plant leaves are not that bad in the photos and if you maintain your watering management and correct lighting the spots should stop. I don't think you have mosaic virus at this time.
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top