Peperomia leaf SOS


Joined
Nov 2, 2020
Messages
1
Reaction score
0
Country
United Kingdom
Hello, I've had this plant for over a year and its alive and has grown an extra shoot/tree which has been growing steadily along with the main tree. The only problem is, it keeps losing leaves and they don't grow back. It forms green nubs but no new leaves form, maybe its not supposed to? It only ever has a small amount of leaves at the top.
I've tried watering it less, moving to a sunnier spot, moving it to somewhere with no direct sunlight, repotted it. Its in an orchid medium and I havent fed it.
I cant find the information I'm looking for, its mostly about overwatering them which I'm sure I'm not doing.
Does anyone have suggestions, I really want more of those lovely velvet leaves!
 

Attachments

  • 20201102_194956.jpg
    20201102_194956.jpg
    148 KB · Views: 53
  • 20201102_195031.jpg
    20201102_195031.jpg
    75.7 KB · Views: 38
Ad

Advertisements

Joined
Mar 22, 2017
Messages
2,648
Reaction score
2,196
Location
Kent
Country
United Kingdom
Welcome @Louise :)

I think your plant would be better off in some peaty compost - not orchid medium - that`s for orchids!
I should have been fed earlier in the summer months while it was in growth - but if it were mine I would repot it, and feed it with slow release fertiliser when new growth starts in the spring. Osmocote pellets are best. Make sure it has good drainage and water it in well to start off with. Do not put it in direct sunlight (not that we`ll get much more of that now)

If you can get a small bag of good compost it will have some feed in it to help the plant along initially.

Plants are a bit like us - if you don`t feed them they go skinny. Feed them and they flourish - even get fat :eek:
 

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments. After that, you can post your question and our members will help you out.

Ask a Question

Top