Aeonium Succulent - PLEASE HELP ?

Discussion in 'Indoor Plants' started by Hannah, Sep 12, 2018.

  1. Hannah

    Hannah

    Joined:
    Jul 22, 2017
    Messages:
    4
    Likes Received:
    0
    Hi, I have 11 of these Aeonium Kiwi CV plants that were cuttings taken from my mother plant and grown on. Only 4 out of the 11 are showing signs of change in their leaves that I have never experienced in the 2 years I have grown a successful amount on. I looked over the plant with an eye loop and can see no visible pests, mealy bugs etc. The roots also appear to be healthy. The plant hasn't been under watered or over watered. They are in a well draining soil mixture and were only recently potted up 4 weeks ago from a 5.5cm pot to an 8cm pot in the same soil mixture I use for all my succulents which are thriving (so it's not like I changed the soil brand etc) I would also like to mention that my plants are grown indoors.

    I have attached 4 photos of the leaf markings, The overall plant health seems fine the damage is only on 2-3 leaves per plant.

    I would really appreciate if anyone has any ideas what this could be and a course of action???

    Thanks very much to anyone that takes the time to help. I hate to see any of my plants unwell but what's worse is not knowing what it is and how to rectify it.

    Thanks again, Larah 1.jpg 2.jpg 3.jpg 4.jpg
     
    Hannah, Sep 12, 2018
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.